Παράδειγμα Άσκησης με ΜΕΧΡΙΣ_ΟΤΟΥ

Να γράψετε πρόγραμμα το οποίο, θα διαβάζει τους βαθμούς 100 μαθητών καθώς και το φύλο τους. Να γίνεται έλεγχος εγκυρότητας των δεδομένων, ώστε οι βαθμοί να είναι από 0 μέχρι και 20 και το φύλο Α ή Κ. Να υπολογίζεται και να εμφανίζεται:

1. Ο μέσος όρος βαθμολογίας των κοριτσιών.
2. Πόσα αγόρια προάγονται (βαθμός μεγαλύτερος ή ίσος του 10)
3. Το φύλο του μαθητή που πήρε τον μεγαλύτερο βαθμό (υποθέστε πως δεν υπάρχει ισοβαθμία)

ΠΡΟΓΡΑΜΜΑ ΜΑΘΗΤΕΣ
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: Ι, Ν1, Ν2
ΠΡΑΓΜΑΤΙΚΕΣ: Β, Σ1, ΜΟ1, ΜΑΧ
ΧΑΡΑΚΤΗΡΕΣ: Φ, Φ_ΜΑΧ
ΑΡΧΗ
Ν1<--0
Ν2<--0
Σ1<--0
ΜΑΧ<-- -1
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ‘ΔΩΣΕ ΤΟ ΒΑΘΜΟ ΤΟΥ ΜΑΘΗΤΗ’, Ι
ΔΙΑΒΑΣΕ Β
ΜΕΧΡΙΣ_ΟΤΟΥ Β>=0 ΚΑΙ Β<=20
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ‘ΔΩΣΕ ΤΟ ΦΥΛΟ ΤΟΥ ΜΑΘΗΤΗ’, Ι
ΔΙΑΒΑΣΕ Φ
ΜΕΧΡΙΣ_ΟΤΟΥ Φ= ‘Α’ Η Φ= ‘ Κ’
ΑΝ Φ= ‘Κ’ ΤΟΤΕ
Ν1<--Ν1+1
Σ1<--Σ1+Β
ΤΕΛΟΣ_ΑΝ
ΑΝ Φ= ‘Α’ ΚΑΙ Β>=10 ΤΟΤΕ
Ν2<--Ν2+1
ΤΕΛΟΣ_ΑΝ
ΑΝ Β>ΜΑΧ ΤΟΤΕ
ΜΑΧ<--Β
Φ_ΜΑΧ<--Φ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ Ν1>0 ΤΟΤΕ
ΜΟ1<--Σ1/Ν1
ΓΡΑΨΕ ‘ΜΕΣΟΣ ΟΡΟΣ ΚΟΡΙΤΣΙΩΝ:’, ΜΟ1
ΑΛΛΙΩΣ
ΓΡΑΨΕ ‘ΔΕΝ ΔΟΘΗΚΑΝ ΚΟΡΙΤΣΙΑ’
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ ‘ΠΡΟΑΓΟΝΤΑΙ’, Ν2, ‘ΑΓΟΡΙΑ’
ΓΡΑΨΕ ‘Ο ΠΡΩΤΟΣ ΜΑΘΗΤΗΣ ΗΤΑΝ’, Φ_ΜΑΧ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ